re = /(\b[a-zA-Z]{3,9}\b)/
str = 'Michael Franz Tim Mike Stefan Jan Felix Lothar Sebastian Alexander Joachim'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end