// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\b[a-zA-Z]{3,9}\b)").unwrap();
let string = "Michael Franz Tim Mike Stefan Jan Felix Lothar Sebastian Alexander Joachim";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}