#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[-+]?([1-9]*[0-9]?\.|0\.)?[0-9]+([eE][-+]?[0-9]+)?$"
Local $sString = "0.000000" & @CRLF & _
"-0.00000" & @CRLF & _
"+0.0000" & @CRLF & _
".1" & @CRLF & _
"+.1" & @CRLF & _
"-.1" & @CRLF & _
"+00000.1" & @CRLF & _
"-00000.1" & @CRLF & _
"000000000000000.1" & @CRLF & _
"000.1111" & @CRLF & _
"00.11" & @CRLF & _
"0.1" & @CRLF & _
"-0.1" & @CRLF & _
"+0.1" & @CRLF & _
"1.1" & @CRLF & _
"+1.1" & @CRLF & _
"-1.1" & @CRLF & _
"10.11" & @CRLF & _
"+10.11" & @CRLF & _
"+10.11" & @CRLF & _
"100.11" & @CRLF & _
"+100.11" & @CRLF & _
"-100.11" & @CRLF & _
"1000.111" & @CRLF & _
"+1000.111" & @CRLF & _
"-1000.111"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")