re = /^[-+]?([1-9]*[0-9]?\.|0\.)?[0-9]+([eE][-+]?[0-9]+)?$/m
str = '0.000000
-0.00000
+0.0000
.1
+.1
-.1
+00000.1
-00000.1
000000000000000.1
000.1111
00.11
0.1
-0.1
+0.1
1.1
+1.1
-1.1
10.11
+10.11
+10.11
100.11
+100.11
-100.11
1000.111
+1000.111
-1000.111'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end