import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?:Mon(?:day)?)|(?:Tue(?:sday)?)|(?:Wed(?:nesday)?)|(?:Thu(?:rsday)?)|(?:Fri(?:day)?)|(?:Sat(?:urday)?)|(?:Sun(?:day)?))";
final String string = "Nos dois sistemas.\n\n"
+ "Em 22 de maio de 2018 10:23, Sistema Delta <sistemaerp@deltasi.com.br>\n"
+ "escreveu:\n\n"
+ "> ##- Não escreva abaixo desta linha -##\n"
+ ">\n"
+ "> *Comentário adicionado por FERNANDO TEIXEIRA BARROS em 22/05/2018 10:23*\n"
+ "> *Usuário:* FERNANDO TEIXEIRA BARROS* Data:* 22/05/2018 10:23:25\n"
+ ">\n"
+ "> *COMENTÁRIO:*\n"
+ "> Bom dia Mayla,\n"
+ "> Apenas sistema Montafarma?\n"
+ "> ------------------------------\n"
+ ">\n"
+ "> *ID Reporte: * #1468\n"
+ "> *Situação: * *ABERTO*\n"
+ "> *Módulo:* Produção\n"
+ "> *Tela:* ordem de pedido\n"
+ "> *Nome: * mayla.capana - MAYLA CAPANA\n"
+ "> *Emissão: * 22/05/2018 12:00:00\n"
+ "> *Fechamento: * -\n"
+ "> *Responsável: * DELTA SI\n"
+ "> *Prioridade: * Urgente\n"
+ "> *Tipo: * Ajuda\n"
+ ">\n"
+ "> *MENSAGEM: *\n"
+ "> Bom dia,\n"
+ ">\n"
+ "> Por favor liberar o meu acesso, Izac e Priscila, para a tela de Produção -\n"
+ "> Ordem de Pedido. (igual a tela que a Iza tem acesso).\n"
+ ">\n"
+ "> Aguardo retorno.\n"
+ ">\n"
+ "> Até,\n"
+ ">\n"
+ ">";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}