re = /(?:(?:Mon(?:day)?)|(?:Tue(?:sday)?)|(?:Wed(?:nesday)?)|(?:Thu(?:rsday)?)|(?:Fri(?:day)?)|(?:Sat(?:urday)?)|(?:Sun(?:day)?))/m
str = 'Nos dois sistemas.
Em 22 de maio de 2018 10:23, Sistema Delta <sistemaerp@deltasi.com.br>
escreveu:
> ##- Não escreva abaixo desta linha -##
>
> *Comentário adicionado por FERNANDO TEIXEIRA BARROS em 22/05/2018 10:23*
> *Usuário:* FERNANDO TEIXEIRA BARROS* Data:* 22/05/2018 10:23:25
>
> *COMENTÁRIO:*
> Bom dia Mayla,
> Apenas sistema Montafarma?
> ------------------------------
>
> *ID Reporte: * #1468
> *Situação: * *ABERTO*
> *Módulo:* Produção
> *Tela:* ordem de pedido
> *Nome: * mayla.capana - MAYLA CAPANA
> *Emissão: * 22/05/2018 12:00:00
> *Fechamento: * -
> *Responsável: * DELTA SI
> *Prioridade: * Urgente
> *Tipo: * Ajuda
>
> *MENSAGEM: *
> Bom dia,
>
> Por favor liberar o meu acesso, Izac e Priscila, para a tela de Produção -
> Ordem de Pedido. (igual a tela que a Iza tem acesso).
>
> Aguardo retorno.
>
> Até,
>
>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end