# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:(?:Mon(?:day)?)|(?:Tue(?:sday)?)|(?:Wed(?:nesday)?)|(?:Thu(?:rsday)?)|(?:Fri(?:day)?)|(?:Sat(?:urday)?)|(?:Sun(?:day)?))"
test_str = ("Nos dois sistemas.\n\n"
"Em 22 de maio de 2018 10:23, Sistema Delta <sistemaerp@deltasi.com.br>\n"
"escreveu:\n\n"
"> ##- Não escreva abaixo desta linha -##\n"
">\n"
"> *Comentário adicionado por FERNANDO TEIXEIRA BARROS em 22/05/2018 10:23*\n"
"> *Usuário:* FERNANDO TEIXEIRA BARROS* Data:* 22/05/2018 10:23:25\n"
">\n"
"> *COMENTÁRIO:*\n"
"> Bom dia Mayla,\n"
"> Apenas sistema Montafarma?\n"
"> ------------------------------\n"
">\n"
"> *ID Reporte: * #1468\n"
"> *Situação: * *ABERTO*\n"
"> *Módulo:* Produção\n"
"> *Tela:* ordem de pedido\n"
"> *Nome: * mayla.capana - MAYLA CAPANA\n"
"> *Emissão: * 22/05/2018 12:00:00\n"
"> *Fechamento: * -\n"
"> *Responsável: * DELTA SI\n"
"> *Prioridade: * Urgente\n"
"> *Tipo: * Ajuda\n"
">\n"
"> *MENSAGEM: *\n"
"> Bom dia,\n"
">\n"
"> Por favor liberar o meu acesso, Izac e Priscila, para a tela de Produção -\n"
"> Ordem de Pedido. (igual a tela que a Iza tem acesso).\n"
">\n"
"> Aguardo retorno.\n"
">\n"
"> Até,\n"
">\n"
">")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.