package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Mytext(?:.*?[\r\n])+EndofMyText`)
var str = `Anytext
Mytextstartshere
more text
more text
EndofMyText
LastTet`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}