re = /Mytext(?:.*?[\r\n])+EndofMyText/
str = 'Anytext
Mytextstartshere
more text
more text
EndofMyText
LastTet'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end