$re = '/Mytext(?:.*?[\r\n])+EndofMyText/';
$str = 'Anytext
Mytextstartshere
more text
more text
EndofMyText
LastTet';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);