using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"kak-ukrasit-interer-rakushkami\/[0-9]{1,}-[0-9]{1,}(\/|)";
string input = @"kak-ukrasit-interer-rakushkami/32-3/
kak-ukrasit-interer-rakushkami/32-3
kak-ukrasit-interer-rakushkami/35-6/
kak-ukrasit-interer-rakushkami/35-61
kak-ukrasit-interer-rakushkami/
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}