// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)kak-ukrasit-interer-rakushkami\/[0-9]{1,}-[0-9]{1,}(\/|)").unwrap();
let string = "kak-ukrasit-interer-rakushkami/32-3/
kak-ukrasit-interer-rakushkami/32-3
kak-ukrasit-interer-rakushkami/35-6/
kak-ukrasit-interer-rakushkami/35-61
kak-ukrasit-interer-rakushkami/
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}