re = /kak-ukrasit-interer-rakushkami\/[0-9]{1,}-[0-9]{1,}(\/|)/m
str = 'kak-ukrasit-interer-rakushkami/32-3/
kak-ukrasit-interer-rakushkami/32-3
kak-ukrasit-interer-rakushkami/35-6/
kak-ukrasit-interer-rakushkami/35-61
kak-ukrasit-interer-rakushkami/
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end