$re = '/([\'"`]).*?\1/';
$str = 'Split on spaces, except "for this", and \'this section\', and `ignore this too`.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);