re = /(['"`]).*?\1/
str = 'Split on spaces, except "for this", and \'this section\', and `ignore this too`.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end