import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\r\\n|^).{1,18}(?=(\\r\\n|$))";
final String string = "фундаментные\n"
+ "опора подвижная\n"
+ "закладные изделия мн 57 1\n"
+ "изготовление металлоконструкций";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}