re = /(\r\n|^).{1,18}(?=(\r\n|$))/m
str = 'фундаментные
опора подвижная
закладные изделия мн 57 1
изготовление металлоконструкций'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end