#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)(gmai|ggmail|gmial|gmaol|gmil|iclould|gmeil|iclouds|icoud|hotmial|yahio|gmell|hotmil|gmailz|iclound|gmaio|gmile|gmaul|iclud|gmsil|gamil|ail|gnail|yhoo|gmal|gmaill|yaho|yshoo|gimail|gemail|gmail\.com)\.(com)$"
Local $sString = "gmai.com" & @CRLF & _
"gmial.com" & @CRLF & _
"gmaol.com" & @CRLF & _
"gmil.com" & @CRLF & _
"iclould.com" & @CRLF & _
"gmeil.com" & @CRLF & _
"iclouds.com" & @CRLF & _
"icoud.com" & @CRLF & _
"ggmail.com" & @CRLF & _
"hotmial.com" & @CRLF & _
"yahio.com" & @CRLF & _
"gmell.com" & @CRLF & _
"hotmil.com" & @CRLF & _
"gmailz.com" & @CRLF & _
"iclound.com" & @CRLF & _
"gmaio.com" & @CRLF & _
"gmile.com" & @CRLF & _
"gmaul.com" & @CRLF & _
"iclould.com" & @CRLF & _
"gmaul.com" & @CRLF & _
"iclud.com" & @CRLF & _
"" & @CRLF & _
"gmsil.com" & @CRLF & _
"yahoo.con" & @CRLF & _
"gamil.com" & @CRLF & _
"gmail.co" & @CRLF & _
"ail.com" & @CRLF & _
"gnail.com" & @CRLF & _
"gmal.com" & @CRLF & _
"gail.com" & @CRLF & _
"yhoo.com" & @CRLF & _
"hmail.com" & @CRLF & _
"gmaill.com" & @CRLF & _
"yaho.com" & @CRLF & _
"yshoo.com" & @CRLF & _
"g.mail.com" & @CRLF & _
"yahoo.co" & @CRLF & _
"g-mail.com" & @CRLF & _
"gmail.comm" & @CRLF & _
"gmail.vom" & @CRLF & _
"icloud.con" & @CRLF & _
"hotmail.con" & @CRLF & _
"gimail.com" & @CRLF & _
"gmail.cim" & @CRLF & _
"gemail.com" & @CRLF & _
"gmail.com.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")