# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(gmai|ggmail|gmial|gmaol|gmil|iclould|gmeil|iclouds|icoud|hotmial|yahio|gmell|hotmil|gmailz|iclound|gmaio|gmile|gmaul|iclud|gmsil|gamil|ail|gnail|yhoo|gmal|gmaill|yaho|yshoo|gimail|gemail|gmail\.com)\.(com)$"
test_str = ("gmai.com\n"
"gmial.com\n"
"gmaol.com\n"
"gmil.com\n"
"iclould.com\n"
"gmeil.com\n"
"iclouds.com\n"
"icoud.com\n"
"ggmail.com\n"
"hotmial.com\n"
"yahio.com\n"
"gmell.com\n"
"hotmil.com\n"
"gmailz.com\n"
"iclound.com\n"
"gmaio.com\n"
"gmile.com\n"
"gmaul.com\n"
"iclould.com\n"
"gmaul.com\n"
"iclud.com\n\n"
"gmsil.com\n"
"yahoo.con\n"
"gamil.com\n"
"gmail.co\n"
"ail.com\n"
"gnail.com\n"
"gmal.com\n"
"gail.com\n"
"yhoo.com\n"
"hmail.com\n"
"gmaill.com\n"
"yaho.com\n"
"yshoo.com\n"
"g.mail.com\n"
"yahoo.co\n"
"g-mail.com\n"
"gmail.comm\n"
"gmail.vom\n"
"icloud.con\n"
"hotmail.con\n"
"gimail.com\n"
"gmail.cim\n"
"gemail.com\n"
"gmail.com.com")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.