import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(gmai|ggmail|gmial|gmaol|gmil|iclould|gmeil|iclouds|icoud|hotmial|yahio|gmell|hotmil|gmailz|iclound|gmaio|gmile|gmaul|iclud|gmsil|gamil|ail|gnail|yhoo|gmal|gmaill|yaho|yshoo|gimail|gemail|gmail\\.com)\\.(com)$";
final String string = "gmai.com\n"
+ "gmial.com\n"
+ "gmaol.com\n"
+ "gmil.com\n"
+ "iclould.com\n"
+ "gmeil.com\n"
+ "iclouds.com\n"
+ "icoud.com\n"
+ "ggmail.com\n"
+ "hotmial.com\n"
+ "yahio.com\n"
+ "gmell.com\n"
+ "hotmil.com\n"
+ "gmailz.com\n"
+ "iclound.com\n"
+ "gmaio.com\n"
+ "gmile.com\n"
+ "gmaul.com\n"
+ "iclould.com\n"
+ "gmaul.com\n"
+ "iclud.com\n\n"
+ "gmsil.com\n"
+ "yahoo.con\n"
+ "gamil.com\n"
+ "gmail.co\n"
+ "ail.com\n"
+ "gnail.com\n"
+ "gmal.com\n"
+ "gail.com\n"
+ "yhoo.com\n"
+ "hmail.com\n"
+ "gmaill.com\n"
+ "yaho.com\n"
+ "yshoo.com\n"
+ "g.mail.com\n"
+ "yahoo.co\n"
+ "g-mail.com\n"
+ "gmail.comm\n"
+ "gmail.vom\n"
+ "icloud.con\n"
+ "hotmail.con\n"
+ "gimail.com\n"
+ "gmail.cim\n"
+ "gemail.com\n"
+ "gmail.com.com";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}