#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^(.*)@(gmai|ggmail|gmial|gmaol|gmil|iclould|gmeil|iclouds|icoud|hotmial|yahio|gmell|hotmil|gmailz|iclound|gmaio|gmile|gmaul|iclud|gmsil|gamil|ail|gnail|yhoo|gmal|gmaill|yaho|yshoo|gimail|gemail|gmail\.com)\.(com)$"
Local $sString = "a@gmail.com" & @CRLF & _
"a@gmai.com" & @CRLF & _
"a@gmial.com" & @CRLF & _
"a@gmaol.com" & @CRLF & _
"a@gmil.com" & @CRLF & _
"a@iclould.com" & @CRLF & _
"a@gmeil.com" & @CRLF & _
"a@iclouds.com" & @CRLF & _
"a@icoud.com" & @CRLF & _
"a@ggmail.com" & @CRLF & _
"a@hotmial.com" & @CRLF & _
"a@yahio.com" & @CRLF & _
"a@gmell.com" & @CRLF & _
"a@hotmil.com" & @CRLF & _
"a@gmailz.com" & @CRLF & _
"a@iclound.com" & @CRLF & _
"a@gmaio.com" & @CRLF & _
"a@gmile.com" & @CRLF & _
"a@gmaul.com" & @CRLF & _
"a@iclould.com" & @CRLF & _
"a@gmaul.com" & @CRLF & _
"ssssa@iclud.com" & @CRLF & _
"" & @CRLF & _
"gmsil.com" & @CRLF & _
"yahoo.con" & @CRLF & _
"gamil.com" & @CRLF & _
"gmail.co" & @CRLF & _
"ail.com" & @CRLF & _
"gnail.com" & @CRLF & _
"gmal.com" & @CRLF & _
"gail.com" & @CRLF & _
"yhoo.com" & @CRLF & _
"hmail.com" & @CRLF & _
"gmaill.com" & @CRLF & _
"yaho.com" & @CRLF & _
"yshoo.com" & @CRLF & _
"g.mail.com" & @CRLF & _
"yahoo.co" & @CRLF & _
"g-mail.com" & @CRLF & _
"gmail.comm" & @CRLF & _
"gmail.vom" & @CRLF & _
"icloud.con" & @CRLF & _
"hotmail.con" & @CRLF & _
"gimail.com" & @CRLF & _
"gmail.cim" & @CRLF & _
"gemail.com" & @CRLF & _
"gmail.com.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")