use strict;
my $str = 'a@gmail.com
a@gmai.com
a@gmial.com
a@gmaol.com
a@gmil.com
a@iclould.com
a@gmeil.com
a@iclouds.com
a@icoud.com
a@ggmail.com
a@hotmial.com
a@yahio.com
a@gmell.com
a@hotmil.com
a@gmailz.com
a@iclound.com
a@gmaio.com
a@gmile.com
a@gmaul.com
a@iclould.com
a@gmaul.com
ssssa@iclud.com
gmsil.com
yahoo.con
gamil.com
gmail.co
ail.com
gnail.com
gmal.com
gail.com
yhoo.com
hmail.com
gmaill.com
yaho.com
yshoo.com
g.mail.com
yahoo.co
g-mail.com
gmail.comm
gmail.vom
icloud.con
hotmail.con
gimail.com
gmail.cim
gemail.com
gmail.com.com';
my $regex = qr/^(.*)@(gmai|ggmail|gmial|gmaol|gmil|iclould|gmeil|iclouds|icoud|hotmial|yahio|gmell|hotmil|gmailz|iclound|gmaio|gmile|gmaul|iclud|gmsil|gamil|ail|gnail|yhoo|gmal|gmaill|yaho|yshoo|gimail|gemail|gmail\.com)\.(com)$/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}