re = /^(.*)@(gmai|ggmail|gmial|gmaol|gmil|iclould|gmeil|iclouds|icoud|hotmial|yahio|gmell|hotmil|gmailz|iclound|gmaio|gmile|gmaul|iclud|gmsil|gamil|ail|gnail|yhoo|gmal|gmaill|yaho|yshoo|gimail|gemail|gmail\.com)\.(com)$/im
str = 'a@gmail.com
a@gmai.com
a@gmial.com
a@gmaol.com
a@gmil.com
a@iclould.com
a@gmeil.com
a@iclouds.com
a@icoud.com
a@ggmail.com
a@hotmial.com
a@yahio.com
a@gmell.com
a@hotmil.com
a@gmailz.com
a@iclound.com
a@gmaio.com
a@gmile.com
a@gmaul.com
a@iclould.com
a@gmaul.com
ssssa@iclud.com
gmsil.com
yahoo.con
gamil.com
gmail.co
ail.com
gnail.com
gmal.com
gail.com
yhoo.com
hmail.com
gmaill.com
yaho.com
yshoo.com
g.mail.com
yahoo.co
g-mail.com
gmail.comm
gmail.vom
icloud.con
hotmail.con
gimail.com
gmail.cim
gemail.com
gmail.com.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end