const regex = new RegExp('^category/(?:(\\w+)/){1,3}offre/(\\d+)/?$', 'gm')
const str = `category/sorganiser/bouger/escalade/offre/78934/
category/sorganiser/savourer/offre/8040/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}