$re = '`^category/(?:(\w+)/){1,3}offre/(\d+)/?$`m';
$str = 'category/sorganiser/bouger/escalade/offre/78934/
category/sorganiser/savourer/offre/8040/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);