// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^category/(?:(\w+)/){1,3}offre/(\d+)/?$").unwrap();
let string = "category/sorganiser/bouger/escalade/offre/78934/
category/sorganiser/savourer/offre/8040/";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}