using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-z0-9_]+$";
string input = @"foo
foo_bar
badThing
meow$cat
meow_cat
thingthing
boop_bop
hello123_thing_boop
hello1Boop
hello";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}