package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-z0-9_]+$`)
var str = `foo
foo_bar
badThing
meow$cat
meow_cat
thingthing
boop_bop
hello123_thing_boop
hello1Boop
hello`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}