// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[a-z0-9_]+$").unwrap();
let string = "foo
foo_bar
badThing
meow$cat
meow_cat
thingthing
boop_bop
hello123_thing_boop
hello1Boop
hello";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}