#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=[0-9a-z,]+$)[^,](?:[^,]{2})*(?:,[^,](?:[^,]{2})*)*$"
Local $sString = "aaffd,123,1,d3213,aaa,f" & @CRLF & _
"1" & @CRLF & _
"2,345,1" & @CRLF & _
"ad,ad" & @CRLF & _
"1,23,1,333"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")