$re = '/^(?=[0-9a-z,]+$)[^,](?:[^,]{2})*(?:,[^,](?:[^,]{2})*)*$/m';
$str = 'aaffd,123,1,d3213,aaa,f
1
2,345,1
ad,ad
1,23,1,333';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);