using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=[0-9a-z,]+$)[^,](?:[^,]{2})*(?:,[^,](?:[^,]{2})*)*$";
string input = @"aaffd,123,1,d3213,aaa,f
1
2,345,1
ad,ad
1,23,1,333";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}