#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!(?:[^ \n]*\ ){4})(?=(?:[^0-9\n]*[0-9]){16}[^0-9\n]*$)[0-9- ]+$"
Local $sString = "1234 567 890 123456" & @CRLF & _
"1234 567 890 12345" & @CRLF & _
"1234 567 890 1234567" & @CRLF & _
"1234 567 890123456" & @CRLF & _
"1234 567890123456" & @CRLF & _
"1234567890123456"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")