const regex = /^(?!(?:[^ \n]*\ ){4})(?=(?:[^0-9\n]*[0-9]){16}[^0-9\n]*$)[0-9- ]+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!(?:[^ \\n]*\\ ){4})(?=(?:[^0-9\\n]*[0-9]){16}[^0-9\\n]*$)[0-9- ]+$', 'gm')
const str = `1234 567 890 123456
1234 567 890 12345
1234 567 890 1234567
1234 567 890123456
1234 567890123456
1234567890123456`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}