re = /^(?!(?:[^ \n]*\ ){4})(?=(?:[^0-9\n]*[0-9]){16}[^0-9\n]*$)[0-9- ]+$/m
str = '1234 567 890 123456
1234 567 890 12345
1234 567 890 1234567
1234 567 890123456
1234 567890123456
1234567890123456'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end