using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)(?<!RT )(?<!RT)@(\w+)";
string input = @"RT @u1, @u2, u3, @u4, rt @u5:, @u3.@u1^, rt@u3";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}