re = /(?i)(?<!RT )(?<!RT)@(\w+)/m
str = 'RT @u1, @u2, u3, @u4, rt @u5:, @u3.@u1^, rt@u3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end