import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s\\d+\\s{0,1}";
final String string = "etett-fqsdfg-4015-0000-sgrghq| 0000000000 | 000000| Data\n\n"
+ "etett-fqsdfg-4015-0000-sgrghq| 11111111111 | 111111 | Data\n\n"
+ "Details\n\n"
+ "Details\n\n"
+ "etett-fqsdfg-4015-0000-sgrghq| 2222222222 | 5555555 | Data\n\n"
+ "etett-fqsdfg-4015-0000-sgrghq| 3333333333 | 6666666 | Data\n\n"
+ "Details";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}