// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\s\d+\s{0,1}").unwrap();
let string = "etett-fqsdfg-4015-0000-sgrghq| 0000000000 | 000000| Data
etett-fqsdfg-4015-0000-sgrghq| 11111111111 | 111111 | Data
Details
Details
etett-fqsdfg-4015-0000-sgrghq| 2222222222 | 5555555 | Data
etett-fqsdfg-4015-0000-sgrghq| 3333333333 | 6666666 | Data
Details";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}