re = /\s\d+\s{0,1}/m
str = 'etett-fqsdfg-4015-0000-sgrghq| 0000000000 | 000000| Data
etett-fqsdfg-4015-0000-sgrghq| 11111111111 | 111111 | Data
Details
Details
etett-fqsdfg-4015-0000-sgrghq| 2222222222 | 5555555 | Data
etett-fqsdfg-4015-0000-sgrghq| 3333333333 | 6666666 | Data
Details'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end