import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\/CIP3AdmJobName *\\()([^\\)]+)(\\)[^\\n]+)\\n([^\\(]+\\()([^\\)]+)";
final String string = "%!PS-Adobe-3.0\n"
+ "%%CIP3-File Version 2.1\n"
+ "%-Cip3-PPF-(RD16-2015-11-09)\n\n"
+ "%Mirror:1 Rotation:0\n"
+ "%PPFOnly-Mode\n"
+ "%ASCII-HEX-Imagedata\n\n"
+ "%-------------------------------------------\n"
+ "% Sheet\n"
+ "%-------------------------------------------\n"
+ "CIP3BeginSheet\n"
+ "/CIP3AdmJobCode (686708) def\n"
+ "/CIP3AdmJobName (686708) def\n"
+ "/CIP3AdmSheetName (Sig-2) def\n"
+ "%No TypeOfScreen\n"
+ "/CIP3AdmCreationTime (Tue Feb 07 14:41:38 2017) def\n"
+ "/CIP3AdmSheetLay /Left def\n"
+ " /CIP3AdmPaperGrammage 56.0 def\n"
+ " /CIP3AdmPaperThickness 0.051 mm def\n"
+ "%No /CIP3AdmPaperColor <-InData\n"
+ "/CIP3TransferFilmCurveData [0.0 0.0 1.0 1.0] def\n"
+ "/CIP3TransferPlateCurveData [0.0 0.0 1.0 1.0] def\n"
+ "/CIP3AdmPSExtent [2763.77953 1734.80315] def\n"
+ "/CIP3AdmPaperExtent [ 2412.00000000 1638.00000000 ] def\n"
+ "/CIP3AdmPaperTrf [ 1 0 0 1 -175.88976378 -63.77940283 ] def";
final String subst = "$1$2-$5$3\\n$4$5";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}