const regex = /(\/CIP3AdmJobName *\()([^\)]+)(\)[^\n]+)\n([^\(]+\()([^\)]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\\/CIP3AdmJobName *\\()([^\\)]+)(\\)[^\\n]+)\\n([^\\(]+\\()([^\\)]+)', 'g')
const str = `%!PS-Adobe-3.0
%%CIP3-File Version 2.1
%-Cip3-PPF-(RD16-2015-11-09)
%Mirror:1 Rotation:0
%PPFOnly-Mode
%ASCII-HEX-Imagedata
%-------------------------------------------
% Sheet
%-------------------------------------------
CIP3BeginSheet
/CIP3AdmJobCode (686708) def
/CIP3AdmJobName (686708) def
/CIP3AdmSheetName (Sig-2) def
%No TypeOfScreen
/CIP3AdmCreationTime (Tue Feb 07 14:41:38 2017) def
/CIP3AdmSheetLay /Left def
/CIP3AdmPaperGrammage 56.0 def
/CIP3AdmPaperThickness 0.051 mm def
%No /CIP3AdmPaperColor <-InData
/CIP3TransferFilmCurveData [0.0 0.0 1.0 1.0] def
/CIP3TransferPlateCurveData [0.0 0.0 1.0 1.0] def
/CIP3AdmPSExtent [2763.77953 1734.80315] def
/CIP3AdmPaperExtent [ 2412.00000000 1638.00000000 ] def
/CIP3AdmPaperTrf [ 1 0 0 1 -175.88976378 -63.77940283 ] def`;
const subst = `$1$2-$5$3\n$4$5`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);