import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\/\\*.*?\\*\\/?)|(([ ]+)?\\/\\/.*?$)";
final String string = "/*\n"
+ " Multiline comments.\n"
+ "*/\n"
+ "int some_func(int n) {\n\n"
+ " int i; /* In between line comments */ int j;\n"
+ " int sum;\n\n"
+ " // Single line comments (include all prior spaces/tabs).\n"
+ " for (i = 0; i < n; i++) {\n"
+ " for (j = i; j > 0; j--) {\n"
+ " sum += j; // Inline comments.\n"
+ " }\n"
+ " }\n\n"
+ " /* /* // don't worry about comments in comments! */ */\n"
+ " return sum + 7;\n"
+ "}\n\n"
+ "/**/ //Empty comments.\n\n"
+ "// Comments at the beginning of new line.\n"
+ "int main() {\n"
+ " printf(some_func(5));\n"
+ "}\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}