import Foundation
let pattern = #"(\/\*.*?\*\/?)|(([ ]+)?\/\/.*?$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
/*
Multiline comments.
*/
int some_func(int n) {
int i; /* In between line comments */ int j;
int sum;
// Single line comments (include all prior spaces/tabs).
for (i = 0; i < n; i++) {
for (j = i; j > 0; j--) {
sum += j; // Inline comments.
}
}
/* /* // don't worry about comments in comments! */ */
return sum + 7;
}
/**/ //Empty comments.
// Comments at the beginning of new line.
int main() {
printf(some_func(5));
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)