$re = '/(\/\*.*?\*\/?)|(([ ]+)?\/\/.*?$)/ms';
$str = '/*
Multiline comments.
*/
int some_func(int n) {
int i; /* In between line comments */ int j;
int sum;
// Single line comments (include all prior spaces/tabs).
for (i = 0; i < n; i++) {
for (j = i; j > 0; j--) {
sum += j; // Inline comments.
}
}
/* /* // don\'t worry about comments in comments! */ */
return sum + 7;
}
/**/ //Empty comments.
// Comments at the beginning of new line.
int main() {
printf(some_func(5));
}
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;