import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<div>(?=.*?2018).*?<\\/div>";
final String string = "<div> ffjdklfjdklfjs 2015 ddddd </div> sfsfsfsfsf <div> hkh/ <> -%=:;.éjhjk 2018 dsqkdlmqs </div> fdfdfd </div><div> ffjdklfjdklfjs 2023 ddddd </div> sfsfsfsfsf <div> hkh/ <> -%=:;.éjhjk 2018 / dsqkdlmqs </div> fdfdfd </div>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}