import re
regex = re.compile(r"<div>(?=.*?2018).*?<\/div>", flags=re.MULTILINE)
test_str = "<div> ffjdklfjdklfjs 2015 ddddd </div> sfsfsfsfsf <div> hkh/ <> -%=:;.éjhjk 2018 dsqkdlmqs </div> fdfdfd </div><div> ffjdklfjdklfjs 2023 ddddd </div> sfsfsfsfsf <div> hkh/ <> -%=:;.éjhjk 2018 / dsqkdlmqs </div> fdfdfd </div>"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")