package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)\d*[.,]?\d+\s*(?:k?g|l)\b|\b(?:k?g|l)\s*\d*[.,]?\d+`)
var str = `ABC 200g EFG 5,4 Kg HIL 2x20l
ABC g200 EFG kg 5,4 HIL l 20x2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}