import re
regex = re.compile(r"\d*[.,]?\d+\s*(?:k?g|l)\b|\b(?:k?g|l)\s*\d*[.,]?\d+", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("ABC 200g EFG 5,4 Kg HIL 2x20l \n\n"
"ABC g200 EFG kg 5,4 HIL l 20x2")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")