import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d*[.,]?\\d+\\s*(?:k?g|l)\\b|\\b(?:k?g|l)\\s*\\d*[.,]?\\d+";
final String string = "ABC 200g EFG 5,4 Kg HIL 2x20l \n\n"
+ "ABC g200 EFG kg 5,4 HIL l 20x2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}